EXTENDING EXISTING FILE SYSTEMS ONLINE IN HP-UX

April 05, 2011

EXTENDING ONLINE JFS FILESYSTEMS
If you want to extend /usr from 300MB to 600MB, and there is available space, do the following:
              
1. Determine lvol # of /usr. Type: 

#bdf

Make note of the lvol that is mounted to /usr.

2. Increase lvol6 to 600MB:  
/sbin/lvextend -L 600 /dev/vg00/lvol6 (-L is new size in MB)


3. Extend the file system using OnlineJFS:         
#/sbin/fsadm –F vxfs –b 600m /usr (m is for MB)


In this example you want to extend /usr from 300MB to 600MB but there is no available space in the volume group that the /usr filesystem is on. In this case you would 
extend the volume group, then the logical volume, and finally the filesystem.

1. If adding disk online (disk array), create device files:   

#insf –e   (verify  #ioscan –fnC disk) 


2. Prepare disks for Logical Volume Manager (LVM) structures:    
#pvcreate /dev/rdsk/???


3. Make space available for volgroup:     
#vgextend /dev/vg00 /dev/dsk/c?d?s?


4. Increase lvol6 to 600MB:  
/sbin/lvextend -L 600 /dev/vg00/lvol6 (-L is new size in MB)


5. Extend the file system using OnlineJFS:         
#/sbin/fsadm –F vxfs –b 600m  /usr  (m is for MB)

EXTENDING EXISTING FILE SYSTEMS (If Non ONLINE JFS)

If you want to extend /usr from 300MB to 600MB, and there is available space, do the following:
  a. Determine lvol # of /usr. Type:

#bdf

Make note of the lvol that is mounted to /usr. 
b. Unmount the file system.
    
#umount /usr      

If you run into problems you may have to boot into single user mode, or you may need to kill all processes associated with /usr.

#fuser –k /usr

c. Increase lvol6 to 600MB: 

#/sbin/lvextend -L 600 /dev/vg00/lvol6

d. Resize the file system to size of lvol6          
#/sbin/extendfs /dev/vg00/rlvol6

e. Now mount the file system:           
#/sbin/mount /dev/vg00/lvol6 /usr

f. Make sure changes took effect using bdf.

g. If you are in single user mode, type the following to get to run-level 3:

#init 3
         

Related Posts

Next Article
« Prev Post
Previous Article
Next Post »

No comments